読者です 読者をやめる 読者になる 読者になる

symfony 1.x系で、IE専用のcssやjsを設定する

symfony 1.x系で、view.ymlのstylesheetの設定でIEのバージョンを指定する方法を見つけたので共有

http://stackoverflow.com/questions/6174392/conditional-ie-css-inclusion-in-symfony-1-2

 

view.ymlの設定:

default:
  stylesheets:
    - style_ie8.css: { condition: IE 8 }
    - style_ltie9.css : { condition: lt IE 9}

出力HTML:

<!--[if lt IE 8]><link rel="stylesheet" type="text/css" media="screen" href="/css/style_ie8.css" /><![endif]-->
<!--[if lt IE 9]><link rel="stylesheet" type="text/css" media="screen" href="/css/style_ltie9.css" /><![endif]-->